After Effects Day 2

Today we are going to take a look at some of the 3D capabilities that After Effects has.
This is pretty cool stuff. Understand that | am only going to give you an introduction to
the 3d environment. This is in no way to be considered an “all you need to know”
session. Hopefully it will give you enough information to get started.

Setting up a basic 3D animation in After Effects requires some basic knowledge of
multiple view and moving layers in three-dimensional space, that is the X, Y, and Z axis.
It can be a little discombobulating but I think I can help you understand it. | really
struggled to figure this out, but I think I have a fairly decent understanding to the basics.

We are accustomed to working in two dimensions, the left to right dimension, also known
as the X axis, and the up and down dimension, known as the Y axis. When we are
working in two dimensions, we are working on a flat plane, much like a table top.
Everything that we put on our table top has an x coordinate and a y coordinate that
describes its position on the table.

(Use the Adobe Premiere Box that is in the lab to demonstrate this.)

The 3D world adds a third dimension, the Z axis. Now, instead of working on a table top,
it is as though we are working on the inside of a box. If you could suspend an object in a
box (which is very similar to what we will be doing shortly), that object would have an x
coordinate that would describe its position relative to the left and right side of the box. It
would also have a y coordinate that would describe it position relative to the top and
bottom of the box. But there is another coordinate that we would have to assign in order
to describe its exact position... the z coordinate which describes it position relative to the
front and back of the box.

In AE you can animate objects (and cameras and lights) through all three dimensions and
that is what we are going to be doing during our session today.

Movie Madness

1. Start a new project file and save it as MovieMadness. Import the two single-layer
PS files, MovieReel.psd and MovieMadness2.psd.

2. Create a new comp and make 640 x 480 NTSC
Drag the MovieReel comp onto the timeline and resize it (S) to about 70%

4. Now you need to adjust the anchor point, (A) so that it is in the exact center of the
picture. The anchor point is the point around which the graphic will rotate.

5. Now click on the Action Safe button in the monitor window to turn on the guides.
Adjust the position of the picture so that the center of the reel is in the center of
the monitor window.

6. You can test your settings by opening the Rotation property (R) and rotating the
reel. If you do, undo it or set it back to 0.

7. Right now all we have is a flat layer; we are working ON the box. Now we want
to create a 3D environment for our project. To do that, you can right click on the



clip in the monitor window and select 3D or you can click on the 3D box in the
timeline.

8. You should now be able to see three colored arrows in the middle of your reel,
one for each of the three axes.

9. You can adjust the position in a couple of different ways.

a. One way to do it is to spin down the Position property in the timeline.
Take note of the current settings. (Mine are 320, 239.8, 0) You will want
to return to these settings after you play around with this a bit.

b. Click and hold on any of the numbers and drag to the left or right. Play
around with that for a moment to see how it works.

c. The second method is to hover your mouse over the green arrow in the
monitor window. When you do, the mouse pointer will tell you that this is
the y axis. Click and hold and move the mouse up and down. Undo any
changes that you make.

d. The other axes work the same way. Play around with them
e. Return your position settings to their original position.

10. Now we want to give this a bit more realism. To do that we are going to add the
ability for this layer to cast shadows when we shine a light on it. On the timeline
spin down the material options and click on the OFF setting in the Cast Shadow
setting to turn it on. (It is a toggle switch.)

11. Now duplicate the layer by pressing Ctrl>D.

I want to spend a minute or two talking about 3D views. This one was really difficult
for me to figure out, but it is a real key to being able to do this easily. Think about the
box again. (Use the Premiere Box again.) If | have an object on a table top, (in a 2D
plane) I am pretty limited in the number of ways to view the object. I can view it from
the top or bottom but that is really about all. That changes drastically in a 3D
environment. | can look at it “head on.” In AE that is known as the Active Camera
view. That is what the end viewer will actually see. But I can also look at from the
left side or the right side. (Show them with the box.) AE call this Left and Right.
(duh!) I can also look at from the top and from the bottom. What do you think AE
calls these view? (Top and bottom.) But, in this environment | can also look at things
from other angles. There are three Custom Views in AE that allow you to see you
project from very different perspectives. We are going to play with these views a bit
to give you at least an idea of how they look. | want you to keep in mind that we have
suspended this reel in the middle of a box and now we are going to look at it form
different perspectives.

12. Change views to the Left view. It seems that the reel has disappeared. It hasn’t
disappeared at all, we have simply turned the box around and we are looking at it
from a different perspective. Since it is a flat graphic it appears as a line in the
comp window.
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Remember, we have two layers here. We are going to separate them a bit to give
the effect of being an actual object. You can’t actually do 3D modeling in AE but
you can do some wizardry that will fool the eye. What we are really doing here is
manipulating 2D objects in 3D space.

In the timeline click on the top layer and spin down the anchor point settings.
Change the z-axis anchor point (the third one) to -20. Now change the z-axis
anchor point on the bottom layer to +20. You should now be able to tell, again
looking from the left, that the two layers have some space between them.

Now switch back to the Active Camera view and take a look at the composition.
You can see a little depth here, but now a lot. This is where the custom views
really come in handy. Change to the first of the three custom views and take a
look at the comp.

What we have done here is taken to 2D object and manipulated them a bit in 3D
space to create an authentic looking 3D movie reel.

Since these are two individual layers, right now if we apply some animation to
one of them, in order to get the animation for the other layer exactly same to make
them look like on object would probably take more work than you want to do. AE
has a really cool feature called Parenting that will fix that and make this very
easy.

Select the first layer in the timeline and click on the Parent drop-down. Select the
second (only other) layer as its parent. (You can also use the pic-whip) At this
point, the bottom layer is said to be the parent and the top layer is said to be the
child. Now, all the transform properties that you apply to the bottom layer (the
parent) will be applied to the top layer also... except the opacity property.
Parenting layers is useful for creating complex animations such as linking the
movements of a marionette or depicting the orbits of planets in the solar system.
There is some really good info in the help file about parenting. You should take
the time to read it.

Well then, let’s animate. Open the rotation property for the parent layer (the
bottom layer). Click the stopwatch on the Y Rotation property to set the first
keyframe at the beginning of the timeline.

Now move out to 6 seconds on the timeline and set another keyframe. Change the
Y rotation to 3. That means that in the first 6 seconds of the comp, the reel will
rotate on its Y-axis 3 times.

RAM preview the animation and see what your hand hath wrought.

To make it a bit more real, let’s apply a little bit of keyframe interpolation. We
know from physics that an object doesn’t go from a still state to full speed state
instantaneously. (Well, OK, UFOs do.) The take off slowly and build speed over
time. The same applies to coming to a stop. An object generally slows down over
time until it reaches a stop. Keyframe interpolation allows you to mimic that law
of physics.
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Right click on the first keyframe and select Keyframe Interpolation>Easy Ease
Out. On the second keyframe select Easy Ease In. (Out is like an airplane taking
off. Think of it as moving out from the keyframe. In is like a plane landing.
Thinking of it as the timeline marker coming In to the keyframe.)

RAM preview and see the difference.

Now let’s add our text layer. Click and drag it to the top of the stack. When you
bring it in, by default it is a 2D layer. 2D layers and 3D layers don’t interact. They
are in a different dimension! That can be a really good thing at times. For
example, let’s say that you wanted a movie poster collage to serve as the
background for this comp.

Import PosterBackground.psd and put it on the timeline at the bottom of the stack.
Scrub the time line and you will see again they the reel doesn’t interact with the
background.

For a really nice effect, apply a Gaussian Blur effect to the background clip and
make the blurriness about 6.7.

Now make the MovieMadness layer a 3D layer. Scrub the timeline and see that
the layers now interact with one another. But this is a rather strange interaction.
What is going on here? Change to top view and click on the MovieMadness layer
in the timeline. What do you notice about the position of this layer in relationship
to the other two? It is between them. That’s why when the other two rotate, they
are “slicing through” this layer. Not to worry, we are going to do something about
that now.

Change to the left view. Keep in mind that we are now looking at the box from
the left side.

Scrub the timeline to the point where the reel is at a 90° angle with the title. Take
note how is slices right through the title.

In the timeline, select the text layer (top), find the z-axis arrow (blue) in the
monitor window and drag it to the right until it is just out of reach of the rotating
reel. (Which direction are we really moving the text layer? Think about the box.
We are really moving it closer to the front of the box.)

Change back to Active Camera view, save the comp, and RAM preview it.

Spin down the material options for the text layer and turn on the Casts Shadow
option.

Now you may be wondering why we haven’t seen any shadows yet since we have
some layers that are set to cast shadows. The reason is that we don’t have any real
light sources yet so no shadows are being cast. Let’s create a spot light.

Select Layer>»New> Light. Choose Spot as the type and click the Casts Shadows
check box. Use the following settings;

a. Intensity — 100%
b. Cone Angle —90°
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c. Cone Feather — 50%
d. Color — White for now

e. Shadow darkness - 85%

f.  Shadow diffusion - 20 pixels.

Well that doesn’t look very good does it? Change views to left and tell me what is
going on here. Can you see that the light is actually further down the box than the
text layer? The text layer is behind the box so it is not shedding any light on it at
all. That’s why it is all black.

Select Window>»Workspace>»Two Comp Views. This may get a little crowded,
but this is a really nice feature that gives you some real power. Change the right
monitor to Active Camera. We will leave that one AC all the time. That way we
will be able to see the effects our changes will have without having to switch back
and forth between views. It might be helpful to turn off the background layer for
the moment.

Change the left monitor to Left view.

Click on the Light layer in the timeline. Zoom the monitor window out to about
25% so you can see some palette that is off the screen.

In the monitor window grab the y-axis of the light and drag it up to near the top of
video window (not the empty palette.) Take note of what is happening in the AC
monitor window.

Now find the z-axis handle and drag it to the right, off the video window and into
the empty palette. Take note of what is happening in the AC window. Also don’t
forget that since we are in Left view, we are actually dragging the light towards
the front of the box. Can you see the shadows?

Now | want you to notice that at the end of the light there is a little circle. That is
called the Point of Interest Handle and you can adjust it independently of the
position of the light itself. Drag that handle down to the center of the MovieReel.

Change to Front view and re-position the light to be slightly off center, at about
12:30. Be sure that the Point of Interest is dead center.

You can RAM preview if you want to. It will take a while but the effect is quite
stunning | think.

Now move the timeline indicator to the first frame. (Home)

Open the Position property, move the timeline indicator out to 6:00 and click on
the stopwatch to set a keyframe for the final position of the text layer. Now move
back to the beginning of the timeline and change the z-axis to -890. Set your left
monitor back to Left view and take a look at what happened. You may have to
zoom out to 12.5% to see it. The text layer is now behind the light and actually
behind the default camera so it is out of view in the AC window.

We are going to make the text fly in from behind the camera. For another little
dose of realism, we are going to add a motion blur to it so it really looks like it’s
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moving, and we are going to animate the motion blur so that as it settles into
place, the blur disappears. Cool, huh?

Be sure you are at the beginning of the timeline and the text layer is selected.
Apply Effects>Blur & Sharpen’> Directional Blur. Leave the direction setting at 0
and change the Blur Length to 10. Turn on the stopwatch to add a keyframe. (This
can all be done on the timeline also.)

Move out to 6 Seconds and change the blur length to 0.

Change the second position keyframe on the text layer to an Easy Ease In
keyframe.

RAM preview at ¥ Resolution to make sure all the animation is looking good.
Things are still a little dark aren’t they? Let’s see if we can fix that.
Add a second light layer. Make this one an ambient light set at 35% intensity.

You can adjust the color the light by double clicking it in the timeline. Do that
now and play around with the color of the light and see what different effects you
can get.

You can turn on the background if you want to. | actually like this one better with
a black background.

Save and RAM preview.
You can add music and try it with and without the background if you like.

Falling Leaves

Now that you have some experience working in a 3D environment, positioning lights,
and changing work views, its time to take it to the next level. In this comp we are going
to explore working with cameras and you are going to learn how to fly a camera through
a 3D scene. This is where it gets really cool. The view that we are going to create is of a
leaf falling through a tree to the ground. The camera will be a leaf and there will be many
others as well.

1.

Create a new comp and name it falling leaves. Make it NTSC 640 x 480 and make
it about 6 seconds long.

Create a new folder in the project window and name it falling leaves. Import the
following psd’s into the new folder. Import them as compositions.

Branch
Grass
Leafl
Leaf?2
Maplel
Maple2

Drag the grass comp onto the timeline

—~® Q0o
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Make the layer a 3D layer and set the z-axis position setting to 1800.
Scale it up to 175%, making it just slightly larger than the frame window.

Zoom out to 12.5% and change to left view to get a feel for where this layer is
relative to the frame window.

Add a camera, Layer>New>Camera. As you can see, there are a lot of options
available for setting the camera. For now all we need to do is select the 50mm
preset. Do that now and click OK.

You should have noticed a couple of things here; the camera is places on the
timeline as another layer. That means you can control it just like you control any
other object on the timeline. You should also be able to see the camera in your
monitor window. That gives you an idea of where it is relative to the rest of the
objects in the comp. If you go back to AC and zoom the window up to 100% you
will so nothing has changed and that is just what we want at this point in time.

We are going to be flying the camera in a straight line over the comp. In order to
keep everything lined up, let’s add a guideline to the comp window. Press Ctrl>»R
to view the rulers. Drag a guideline from the ruler down to the middle of the
composition.

Drag the Point of Interest circle from the camera down to the center of the grass
layer. (You may have to move the guideline down a bit in order to be able to grab
the POI circle. That is ok. Just put it back when you are finished to be sure that
the POI is perfectly aligned with the camera.

On the timeline select the Camera 1 layer and open the position settings. Click on
the stopwatch with the current timeline indicator at the beginning of the comp.

Move out to 5:00 and change the z-axis position to 900. You could also do this in
the monitor window by clicking on the camera and dragging it to the left until it is
right next to the grass layer.

Scrub the timeline and see that the camera is zooming in on the grass. (You
should do this while viewing the active camera.)

Drag the Branch comp to the timeline and convert it to 3D.

This layer is going to be static as the camera passes by it so let’s just put it into
position by setting the z-axis to — 370

The branch layer seems to be a bit dark in comparison to the grass layer. It
doesn’t really look like they are in the same light. Let’s fix that. Select
Effect> Adjust>Levels and play around with the Input White setting. | am going
to use a setting of 170. | am also going to set the Gamma setting to 1.30. When
we add some lights to the scene a little later, the leaves will appear more natural.

Now we are going to duplicate the branch layer. But first you need to press the F2
key to deselect everything. Then click on the layer that you want to duplicate and
press (Ctrl>»D).
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Select the new branch layer (the bottom one) and change the Z-Rotation setting to
180°. Change the position settings to 223, 178.6, -120.

Change to left view and take a look at the two leaf layers to see how they are
related, how those setting separated the layers.

Also be sure to take a look at the scene now in AC view. Toggle off the bottom
layer and the top leaf layer in order to see what the change in settings has done.

We want this layer to be a little darker than the first branch layer, since the light
will be shining on the lower branches more in the project. Set the Input white to
220. | am also going to set the Gamma to 1.10. This will make this lower set of
leaves a little darker than the top set, again giving it a bit more realism.

Now we are going to do that one more time... one more branch. Duplicate it (be
sure to deselect everything first, then select the bottom branch layer). Change the
following settings...

a. Z-Rotation +345°
b. Position +324.6, 254.1, 290
c. White Input +255

Scrub the timeline and see the camera fly though the leaves. Cool? The camera
appears to be heading straight for the ground through the tree branches. The is no
scaling or zooming in this effect, only natural camera motion.

Put the Leafl Comp in the timeline with the following settings. The comp needs
to start at 0 on the timeline but you probably want to move you timeline marker
out to 5:00 to apply and fine tune these settings.

a. 3D Layer
b. Scale - 40%
c. Cast Shadows — On
d. Z-axis (position) to 1790 (10 pixels above the grass)
e. Z-Rotation — Negative 80° (rotation)
f. Position +227.9, 306.1, 1790 (position)
g. You can adjust the level settings if you like
Put the Leaf 2 Comp on the timeline with these settings
a. 3D Layer
b. Scale - 40%
c. Cast Shadows — On
d. Z-axis to 1780 (position)
e. Z-Rotation — 0° (rotation)
f. Position +465.5, 142, 1780 (position)
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You can adjust the level settings if you like

26. Put maplel comp on the timeline with these settings.

0.
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3D Layer

Scale — 40%

Cast Shadows — On

Z-axis to 1770 (position)

Z-Rotation +15° (rotation)

Position +365, 269.4, 1770 (position)

You can adjust the level settings if you like

We have now established the final resting place for the three leaves. Now let’s put
them into motion. We are going to animate them to fall to the ground slightly ahead
of the camera’s motion path. Even though we have created resting places for the
leaves, we don’t want them all to fall at the same time and at the same rate. They will
all end their motion paths at different times to give the animation a more realist look

and feel.

27. Start with the last frame of each layer’s motion path, the final resting place. That
is going to be at 5:00. Turn on the animation stop watch for each layer’s position
and rotation settings. That will set a keyframe at the end of the animation. Add the
Ease In interpolation to each of the keyframes.

28. For the leafl comp use the following settings...

a.

b.

C.

At 00:16
1. Position - -104.7 (negative 104.7), 561.8, 100
2. Z-Rotation - -19° (negative 19)
At 1:26
1. Position - -1.5 (Negative 1.5), 280, 877
At 3:13
1. Position 227.9, 306.1, 1750
2. Z-Rotation - -80° (negative 80)

3. Keyframe Assistant — Easy Ease In (Note, if the leaf disappears
below the grass, you can right click on the Position Keyframe at
3:13 and set the spatial Interpolation to Linear. This should keep
the leaf visible.)

RAM preview your composition and see what you think.

Next create an animation path for the other two leaves. Move the current timeline marker
to 5:00 and turn on the animation stop watch for the position, x-rotation, y-rotation, and
z-rotation. Move back to the beginning (or slightly after the beginning) and begin the
animation. You decide on the settings.



Now we are ready to add some light to the scene which will add depth and dimension to
the animation.
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Select Layer>New>>Light and choose Spot Light, 100% Intensity, and a warm
yellow light color.

Switch to left view and drag the light above and to the left of the camera. (To see
the camera, click on it in the timeline. You may have to use the Track XY Camera
tool in the tool bar to bring it into view.) You should adjust the Y and the Z
coordinates to get the light above and to the left of the camera.

Now drag the Point of Interest circle for the light to the center of the grass layer.
Again, you may have to use the Track XY Camera tool to do this. If your
camera’s point of interest is not centered on the grass, you should move it now.

Move the Timeline Indicator to 5:00 and open the Light 1 layer Options settings
in the Timeline. Click the Shadow Stopwatches and turn on the Casts Shadow
option. This sets the ending point of the animation for this light. Use the following
settings for the Shadow options.

a. At 2:00, shadow darkness — 0%
b. At 2:19, shadow darkness — 35%
c. At5:00, shadow darkness 70%, shadow diffusion 10 pixels

Scrub your timeline (you may have to scrub and stop, scrub and stop to allow you
screen time to redraw the correct image.) It seems kind of dark and muddy,
doesn’t it? Do you remember what we did earlier to fix this problem? We added
an ambient light.

Select Layer>New)>Light and choose Ambient light. | played around with it and
I like an intensity of 75% and a color value of FBEBC3. Play around with those
settings until you find something that works for you.

Save the project and do a RAM preview.

Money In Motion

In this animation we are going to be animating a camera, a light source, and some other
objects all at the same time. Adding motion to multiple elements can really take your
animation to the next level. We are also going to duplicate some animated layers and
redistribute them to create a complex animation in a short amount of time.

1.
2.
3.

Create a new comp and name it MoneyInMotion.
Make it 640 x 480 and 6 seconds in length
Import the following files...

a. MoneyBackground — as footage

b. CoinStacks.psd as composition with cropped layers (using the cropped
layers option will trim the unwanted transparent space around the layer
objects so they can be properly scaled and placed.)



c. Five-dollars as composition with cropped layers
Drag the background file onto the timeline and convert it to a 3D layer.

5. Open the left side view and drag the X-axis arrow to the left about 1000 pixels.

10.

11.

12.

(Or, you can use the position setting on the timeline to do this.)
Duplicate the layer (Click on the layer and press Ctrl>D)

Now we want to move the duplicated layer up in the left view. The easiest way to
do this is with the Y-axis setting in the Position settings in the timeline. Set the Y-
axis value at -1928.

Also set the Z-axis at 1008, slightly behind the original so the seam won’t show in
the final rendering.

Create a new camera layer and use the 50mm preset.

Again, from the left side view move the camera to a position below the
background and set the Point of Interest circle to a position near the bottom of the
background.

Bring in the four coin pictures and make them 3D layers and set them to 60%
scale.

For a starting position, the place from which we will begin to play, use the
following....

a. Quarters
i. Position 91, 586.2, 906
ii. Scale 60%
iii. X rotation 90°
b. Dimes
i. Position 504, 780, 900
ii. Scale 60%
iii. X rotation 90°
c. Nickels
i. 536,416, 909
ii. 60%
iii. 90°
d. Pennies
i. 172,188, 896

13. Now switch to left view and zoom out to 12.5%. Select the four coin layers in the

timeline,

14. Press Ctrl>»D to duplicate the layers.



15. With the layers still selected, in the left view window, click on the z-axis arrow on
any of the pictures and move it toward the top of the screen. Repeat this step one

more time. (We are duplicating and repositioning the four coin layers.)

16. Now animate the camera and Point of Interest with the following settings

Transform | 00:00 1:15 3:00 4:15 5:00 5:26
Point of 272 272 272 272
Interest | gg 712 1864 2416

848 896 888 1048
Position 272 272 272 272 272 272

1856 984 16 -1288 -1688 -2096

311.1 815.1 863.1 871.1 575.1 575.1
Keyframe Easy Ease
Assistant In

17. Save and RAM preview your comp.

18. Import the Million Dollar, One Dollar, and ten dollar jpegs.
19. Set the $10 bill as follows

Transform 00:00 1:00 1:08
Position -504 484 540
507 517 507.4
596 998 998
X Rotation 15° 0°
Y Rotation -10° 0°
Keyframe Easy Ease In
Assistant
Casts Shadows On
20. Set the One Dollar bill as follows...
Transform 00:00 15 1:00 1:09
Position 1059.2 | 680.3 287.2 652.2
-2151.1 | 214.9 215.1 215.1
975.1 998.2 801.6 998
X Rotation 0° 0° 15° 0°
Y Rotation Q° 0° -6° 0°
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Keyframe

Assistant
Casts Shadows | On Easy Ease In
Use the following settings for the Million Dollar Bill
Transform 00:00 1:22
Position 78 296
-409.6 -409.6
350 1088
X Rotation 0° 8
Y Rotation
Keyframe
Assistant
Casts Shadows

Now duplicate and move them like you did the coins. What | did is simply
adjusted the position of the in point for each set of coins so they all start a
different points on the timeline.

Scrub you timeline and make adjustment to the position of the new bills as
needed.

Now let’s apply some lighting. We are going to add two lights, a spot to cast
shadows and an ambient light to warm things up a bit.

Add a new light, Spot » 100% » Casts Shadows » Shadow Darkness 85% »
Shadow Diffusion 20 pixels.



